Is gvedit depreciated?

Hello,

First, I want to thank everyone that volunteers their time to maintain this package. I attempt to maintain FOSS software on FreeBSD in my “free time” (free time being the hours I’m supposed to be sleeping) and I know how much effort is required.

Background:
The company/team I work for is slowly adopting the gvedit program for generating state graphs and I have been asked to maintain some diagrams. I tried installing graphviz/gvedit on Ubuntu 20 first. The apt package doesn’t have a binary for gvedit and stack overflow recommends compiling it manually: https://askubuntu.com/questions/1060516/how-to-get-gvedit-gvedit-graph-file-editor-for-ubuntu

The instructions do not seem to work on Ubuntu 20. From what I can tell, qt4 is depreciated. I tried building against qt5 but to no avail. Obviously, I could have made a mistake and the ubuntu packages are maintained by someone else, but I thought I would point out that gvedit is not readily available on Ubuntu 20.

So, I switched over to windows hoping for a quick win, but it appears gvedit is only available in 2.38 as per the thread here: Windows : Where is GVedit.exe?

I haven’t yet installed choco to attempt to get gvedit, but the link you provided for the download page no longer contains a link to 2.38. The only available download version I could l could find is 2.44.

(Update) I have actually managed to get a working copy in Windows by zipping someone else’s install and unzipping it on my windows VM. It seems to work so far.

Question:

SO, finally to my real question: Is gvedit depreciated and being removed? I know very little about the program at this point but I would like to ask if there is an alternative to gvedit if it is indeed being depreciated? Are there similar functions available from the command line?

Once again, thank you for your efforts and time to maintain GraphViz.

gvedit is not deprecated, but it’s not present in any modern Windows release, only in version 2.38 avaiable at https://www2.graphviz.org/Archive/stable/windows/graphviz-2.38.msi.

We are in the process of making it available in an upcoming Windows release. A WIP MR is available at:

but it’s not quite ready yet.

We are not aware that gvedit is missing from any of the Linux builds, but if you can point to one where it is you are welcome to submit an issue.

You might also want to try:

1 Like

Wow, thank for getting back to me so quickly. And thanks for the thorough response.

Here is the result of my installation from apt on Ubuntu 20. Perhaps I’ve missed something? I don’t see gvedit.

rhaley@rbm1:/usr/bin$ apt show graphviz
Package: graphviz
Version: 2.42.2-3build2
Priority: optional
Section: universe/graphics
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Laszlo Boszormenyi (GCS) <gcs@debian.org>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 3,175 kB
Depends: libann0, libc6 (>= 2.15), libcdt5, libcgraph6, libexpat1 (>= 2.0.1), libgcc-s1 (>= 3.0), libgd3 (>= 2.1.0~alpha~), libglib2.0-0 (>= 2.16.0), libgts-0.7-5 (>= 0.7.6), libgvc6 (>= 2.42.1), libgvpr2, liblab-gamut1, libstdc++6 (>= 5), libx11-6, libxaw7, libxmu6, libxt6
Recommends: fonts-liberation
Suggests: gsfonts, graphviz-doc
Homepage: https://www.graphviz.org/
Download-Size: 590 kB
APT-Manual-Installed: yes
APT-Sources: http://ca.archive.ubuntu.com/ubuntu focal/universe amd64 Packages
Description: rich set of graph drawing tools
 Graph drawing addresses the problem of visualizing structural information
 by constructing geometric representations of abstract graphs and networks.
 Automatic generation of graph drawings has important applications in key
 technologies such as database design, software engineering, VLSI and
 network design and visual interfaces in other domains. Situations where
 these tools might be particularly useful include:
 .
   * you would like to restructure a program and first need to understand
     the relationships between its types, procedures, and source files
   * you need to find the bottlenecks in an Internet backbone - not only
     individual links, but their relationships
   * you re debugging a protocol or microarchitecture represented as a
     finite state machine and need to figure out how a certain
     error state arises
   * you would like to browse a database schema, knowledge base, or
     distributed program represented graphically
   * you would like to see an overview of a collection of linked documents
   * you would like to discover patterns and communities of interest in a
     database of telephone calls or e-mail messages
 .
 This package contains the command-line tools.

rhaley@rbm1:/usr/bin$ ll gv*
-rwxr-xr-x 1 root root  22728 Mar  2  2020 gv2gml*
lrwxrwxrwx 1 root root      6 Mar  2  2020 gv2gxl -> gxl2gv*
-rwxr-xr-x 1 root root  49576 Mar  2  2020 gvcolor*
-rwxr-xr-x 1 root root  26784 Mar  2  2020 gvgen*
-rwxr-xr-x 1 root root 577360 Mar  2  2020 gvmap*
-rwxr-xr-x 1 root root   2181 Mar  2  2020 gvmap.sh*
-rwxr-xr-x 1 root root  31112 Mar  2  2020 gvpack*
-rwxr-xr-x 1 root root  14488 Mar  2  2020 gvpr*
rhaley@rbm1:/usr/bin$ gvedit

Command 'gvedit' not found, did you mean:

  command 'gedit' from snap gedit (3.36.2+git3.8c9da67ab)
  command 'bvedit' from deb bvi (1.4.0-1build3)
  command 'gedit' from deb gedit (3.36.2-0ubuntu1)

See 'snap info <snapname>' for additional versions.

I see you have added a link to the deb releases in the stackoverflow I mentioned. Thank you for that. I’ll try uninstalling and using the deb installer.

We do (extremely) basic test of gvedit in our CI. You can see which packages are needed in:

1 Like

I have been compiling with QT5 for about a year (but on a Mac, not Windows). (Do we still call them Macs? Not iLaptop yet?)