Graphviz dot to svg width changing based on where i run it

Hello…I have converted a graph from dot to svg on my local PC and i also ran the same command on an azure webjob which runs on cloud.
on my local PC: width=“4563 pt” height=“2173pt”
viewBox=“0.00 0.00 4562.50 2173.00”

on webjob running on cloud :svg width=“124698pt” height=“2173pt”
viewBox=“0.00 0.00 124697.50 2173.00”

This is for the same graph and i am not setting any ratio or size attributes. Does anyone know why this could be happening

Seems like a bug.

  • Are the two graphs wildly different in appearance?
  • What version(s) of Graphviz? (run dot -V)

Yes the graph sizes are wildly different. The one generated from local PC looks fine…I have also run the same command on another standalone virtual machine which is also fine but the one generated on cloud is too wide to even look at it. All of them have the same version of graphviz
graphviz version 2.38.0 (20140413.2041)

Release 2.38.0 is 8 years old. Release 3.0.0 is available now.

Just tried with latest version
graphviz version 3.0.0 (20220226.1711)
still the same problem

Still seems like a bug, please report it here: Issues · graphviz / graphviz · GitLab