Error: Unable to find a match: glade3-libgladeui-devel

@Ellson (or anyone): In https://gitlab.com/graphviz/graphviz/-/blob/master/redhat/graphviz.spec.fedora.in#L97 glade3-libgladeui-devel is required, but when I try to build a new Docker image for Fedora33, I get Error: Unable to find a match: glade3-libgladeui-devel.

From https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html-single/considerations_in_adopting_rhel_8/index it seems this package no longer exists.

Please advice. I don’t know how any of this stuff works.

If you try to build the Docker image yourself, this is also needed:

diff --git a/ci/fedora33/Dockerfile b/ci/fedora33/Dockerfile
index 4f666c1b5..d85973f94 100644
--- a/ci/fedora33/Dockerfile
+++ b/ci/fedora33/Dockerfile
@@ -30,7 +30,7 @@ RUN yum -y install swig
 # Command smyra
 
 # Command gvedit
-RUN yum -y install qt5-devel
+RUN yum -y install qt5-qtbase-devel
 RUN yum -y install ncurses-devel
 
 # Plugin library devil

Apparently on my local fc33 VM I’m getting glade3-libgladeui-devel-3.8.6-8.fc32.x86_64 from rawhide (note: still fc32)

I need to do some more checking, possibly i shouldn’t be using rawhide at this time …

Re Docker image builds … I’m not capable of doing that at this time, so relying on you. Some more documentation on how to build Docker images for graphviz runners
would be appreciated.

John

Here’s an example for ubuntu-18.04:

docker image build -t graphviz:ubuntu-18.04 ci/ubuntu-18.04
docker tag graphviz:ubuntu-18.04 graphviz/graphviz:ubuntu-18.04
docker push graphviz/graphviz

Concur that glade3-libgladeui-devel is missing from fc33 yum repos. I will report this to Red Hat.

Did you see this above?

Reported:

https://bugzilla.redhat.com/show_bug.cgi?id=1842297

Sorry, that’s a big document. What specifically are you referring to?

Also, the doc is about RHEL8 and not Fedora33 … Are we still talking about glade3 issues?

That glade3-libgladeui-devel is listed under A.4. Removed packages, but I don’t know the relation between RHEL and Fedora versions so it might not be significant.

It turns out that we no longer use anything from that package, so i removed the yum install for it from ci/fedora33/Dockerfile. Will need you help again to rebuild the Docker image.

But I’m hitting some unrelated problem now on fedora33. i think this is in SWIG generated code, so probably a SWIG issue.

gv_ruby.cpp: In function ‘void SWIG_RubyInitializeTrackings()’:
gv_ruby.cpp:1267:85: error: call of overloaded ‘rb_define_virtual_variable(const char [21], VALUE (&)(…), NULL)’ is ambiguous
1267 | rb_define_virtual_variable(“SWIG_TRACKINGS_COUNT”, swig_ruby_trackings_count, NULL);
| ^
In file included from /usr/include/ruby/ruby.h:2863,
from /usr/include/ruby.h:33,
from gv_ruby.cpp:880:
/usr/include/ruby/backward/cxxanyargs.hpp:59:1: note: candidate: ‘void ruby::backward::cxxanyargs::rb_define_virtual_variable(const char*, VALUE ()(…), void ()(…))’
59 | rb_define_virtual_variable(const char *q, type *w, void_type *e)
| ^~~~~~~~~~~~~~~~~~~~~~~~~~
/usr/include/ruby/backward/cxxanyargs.hpp:90:1: note: candidate: ‘void ruby::backward::cxxanyargs::rb_define_virtual_variable(const char*, VALUE ()(…), void ()(VALUE, ID, VALUE*))’
90 | rb_define_virtual_variable(const char *q, type *w, rb_gvar_setter_t *e)
| ^~~~~~~~~~~~~~~~~~~~~~~~~~
make[4]: *** [Makefile:2531: libgv_ruby_la-gv_ruby.lo] Error 1

I already tried that. It won’t succeed since it’s required:

Did you miss my Docker instructions?

OK, removed requirement for glade3-libgladeui-devel from specfile for fc33 or later.

Ignore SWIG comment. I think my local build was just unclean after distro-sync for fc33.

fc33 building ok now locally

1 Like

I think I’m getting messed up by sometimes replying by email and sometimes via discourse, sorry.

I believe I fixed the glade3 issue on fc33 and the ghostscript issue … but I need new Docker images at your earliest convenience, please.

John

This triggered something in my memory, and I realized the error you quoted is basically the same as graphviz#1659. Are these related?

Maybe… But i think I triggered the problem by doing a distro-sync and possibly picking an older
version of SWIG without fully distcleaning my build tree.

A bit of clean up and a second attempt resulted in a clean build. So it was just a local problem, i think.

I never reply by email. I always go the the forum and reply there to get the latest updates.

@Ellson When I try to build for Fedora32, I get:

+ rpmbuild -ta graphviz-2.45.20200531.1836.tar.gz
error: line 99: Unknown tag: glade3-libgladeui-devel

It’s the same error as in https://gitlab.com/graphviz/graphviz/pipelines/151369639

So apparently that package has been removed from all fedora… I’ve never seen a package removed like that before.

Centos7/8 still failing due to missing ghostscript in Docker images

No, that’s not the reason it was failing. It’s was bad syntax in https://gitlab.com/graphviz/graphviz/-/blob/master/redhat/graphviz.spec.fedora.in. I haven’t updated the Dockerfiles yet so the package is still present in the images I use and those that are used in the pipeline.

OK thanks. Syntax fixed instead.

1 Like